Mash - Elevated Memory Usage on Cloud Run Causing Slack Message Processing Delays – Incident details

Elevated Memory Usage on Cloud Run Causing Slack Message Processing Delays

Resolved
Partial outage 50 %
Started 8 days ago

Affected

Dashboard

Operational from 3:00 PM to 12:00 AM

Slack App

Partial outage from 3:00 PM to 7:00 PM, Operational from 7:00 PM to 12:00 AM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    We identified higher-than-normal memory usage on a Cloud Run instance, which caused Slack message processing to hang and delayed message handling. Investigation and mitigation are in progress.